This project is read-only.

Always getting Error Code 0xC000135 or 0x000135

Jun 13, 2016 at 2:29 PM
Edited Jun 13, 2016 at 2:30 PM
Hello Community,

I have a Project with D3D11 and FW1Fontwrapper. The dll should inject into any game with D3D11 and without FW1Fontwrapper initialized it works very well. But when I include FW1Fontwrapper the DLL doesn't get Injected anymore. Everytime when I press the Inject button the Injector crashs instantly. The Error Code is like in the Description.

My OS is Windows 10 x64, and I'm using VS2015

I hope you can help me.
Jun 13, 2016 at 2:41 PM
Edited Jun 13, 2016 at 2:42 PM
Did you rebuild FW1 or did you use a prebuilt DLL?
You probably need to rebuild it on VS 2015 at least..

Make sure FW1 works correctly on that system by building one of the sample projects.. not sure if Win10 might have changed some things, but I think it should still work, but not necessarily if using an old binary that tries to load an older version of some D3D/DirectWrite component. (Could also be the other way around, if you try to inject the DLL into something using older versions it may cause conflicts).

Either way that type of usage is prone to errors and it could just as well be something completely different... it's not a use-case that was ever tested during development.

Searching for 0x00000135 as a HRESULT says ERROR_NOTIFICATION_GUID_ALREADY_DEFINED, perhaps some conflict of the same thing registered or loaded twice or something..
Jun 13, 2016 at 10:47 PM
Edited Jun 13, 2016 at 11:25 PM
Thanks for your Answer.

Yes I'm using eveything of the prebuild DLL and Lib.
When I try to Rebuild FW1 with the Source Code from your page it doesn't work.
It always tells me when I change my Settings to VS2015 that I must have installied Windows 7.1 SDK ?!...

Edit1: So i tried a bit. I installied VS2012 Rebuild the whole FW1 Project. The error happens again.
So I started Injecting the FW1.dll first and then my DLL then it works perfectly. But why happens this error?
Jun 14, 2016 at 9:32 AM
If you right-click the project and go into the Properties view you should be able to change the Windows 7.1 SDK to the Windows 10 SDK, or alternatively there is sometimes an option that something like "upgrade platform" or similar when right-clicking. (I haven't actually tested building with Win10 SDK though..)

Difficult to say what the error might be.. somehow feels like it's probably about dependencies between DLLs.. not sure how that works.
Jun 14, 2016 at 11:21 PM
Thank you for your answer.

I tried that already with a Visual Studio (V140) but that didn't work and I cant choose Windows 10 SDK.
I can only use FW1 when I first inject the Fw1 dll and then my own dll, but that sucks in my opinion...
Maybe it's a problem on my side, but it's very curious..
Jun 15, 2016 at 6:12 AM
Strange, when I open the solution in VS 2015 I see 'Windows 7.1 SDK (not installed)' in Platform Toolset but if I click it I can select 'Visual Studio 2015 (v140)' instead...

You can also create a new project in VS, select Win32 Project, then select DLL and check Empty project. Add all the files from the Source directory in the FW1 code to that new project and it should build correctly.
Jun 16, 2016 at 6:47 PM
So I tried this once and it worked. I could compile it with a new Project.
But the Inject problem still exists.